Cloud Paper - Document Signing Outage
Incident Report for Gearco Cloud
Resolved
The issue has been resolved. Properties may proceed with signing documents.
Posted 6 months ago. Jul 21, 2018 - 15:42 EDT
Identified
The Gearco Cloud Paper communication outage has been identified. eSignlive is working to resolve the issue as soon as possible.
Posted 6 months ago. Jul 21, 2018 - 13:43 EDT
Monitoring
We are currently investigating this issue.
Posted 6 months ago. Jul 21, 2018 - 13:41 EDT
This incident affected: Gearco Cloud Paper.