Credit Card Vault Entry

Incident Report for Gearco Cloud

Update

We are continuing to investigate this issue affecting the entry of new credit cards in the Credit Card Vault. Bank of America and USAePay are actively engaged and working to identify the root cause. We will provide further updates as more information becomes available.
Posted Mar 26, 2026 - 11:07 EDT

Update

We are continuing to investigate this issue.
Posted Mar 25, 2026 - 10:58 EDT

Investigating

We are currently investigating an issue affecting the entry of new credit cards in the Credit Card Vault. Our team is reaching out to Bank of America and will provide updates as they become available.
Posted Mar 25, 2026 - 10:55 EDT
This incident affects: Gearco Cloud Credit Cards (BOA (Payment Fusion Axia) / Credit Card Vault).