Credit Card Vault Entry

Incident Report for Gearco Cloud

Resolved

Bank of America has successfully resolved the CAPTCHA issue. Users should now be able to access and interact with the site without interruption.
If anyone continues to experience access problems or unusual behavior, please clear your browser cache and try again. If the issue persists, report it so we can escalate accordingly.
Thank you for your patience while this was being addressed.
Posted Aug 27, 2025 - 05:17 EDT

Investigating

We are currently investigating an issue affecting the entry of new credit cards in the Credit Card Vault. The problem appears to be related to a new CAPTCHA requirement implemented by Bank of America. Our team is actively working on a resolution and will provide updates as they become available.
Posted Aug 26, 2025 - 05:43 EDT
This incident affected: Gearco Cloud Credit Cards (BOA (Payment Fusion Axia) / Credit Card Vault).